Информатика. Учебное пособие



         

Что такое базовые алгоритмические структуры? - часть 2


/p>

3. Базовая структура  "цикл".

Обеспечивает многократное выполнение некоторой совокупности действий,

которая называется телом цикла. Основные разновидности циклов представлены в таблице:

Школьный алгоритмический язык

Язык блок-схем

Цикл типа пока.

Предписывает выполнять тело цикла до тех пор,

пока выполняется условие, записанное после слова пока.

 нц пока условие   тело цикла   (последовательность действий) кц

Цикл типа для.

Предписывает выполнять тело цикла для всех значений

      некоторой переменной (параметра цикла) в заданном диапазоне.     

 нц для i от i1 до i2   тело цикла   (последовательность действий) кц

Примеры структуры цикл

       Школьный алгоритмический язык      

           Язык блок-схем            

 нц пока i <= 5   S := S+A[i]   i := i+1 кц

 нц для i от 1 до 5   X[i] := i*i*i   Y[i] := X[i]/2 кц




Содержание  Назад  Вперед